Did all of your firefox extensions suddenly stop working today?

firefox
extensions
certificates
#1

It appears that the easiest workaround if you’re not running developer or nightly is to turn on extension debugging and then manually load all of your extensions from disk.

If I had a dime for every time that I heard about some company forgetting to renew a certificate…

11 Likes

#2

I was coming here to say something for this exact reason.

Apparently, there’s some crap going down at the MMORPG Dungeons & Dragons Online too, on the eve of their new expansion launch that corrupted everyone’s DAT files, and the devs have all gone home for the weekend.

I’m getting tired of this autopilot attitude.

4 Likes

#3

Yep. :unamused: Just came here to post this.

I suspect it was a setup - suddenly millions of people are browsing the web without adblockers.

ETA: Can confirm extensions are working in firefox developer edition with xpinstall.signatures.required set to false in about:config. Will use this until standard Firefox is fixed.

6 Likes

#4

It seems like certificate renewal is in a weird space by being at the same time both trivially easy to get right (and thus not requiring the devotion of intellectual firepower) and critically important to get right (and thus requiring high, maybe C-level responsibility and accountability).

How are orgs that people know about handling this responsibility? Diffuse or centralized? Formal policies or up to individuals?

7 Likes

#5

I wouldn’t exactly say that it’s trivially easy. If there’s an issue with the configuration with one of your subdomains, Let’s Encrypt will renew none of them. I learned that the hard way.

4 Likes

#6

Is this going to be fixed? Is there some way to go back to the previous version of Firefox till it is fixed? I’d rather not go to websites without PrivacyBadger and NoScript installed.

1 Like

#7

That’s true, I know, it is complicated. But the remembering to do it part …

2 Likes

#8

A fix is available here. I tried it and it works.

5 Likes

Discourse 2.2 released!
#9

We get a weekly list of all the certificates that are due to expire and every team is expected to go over the list and request new certs for their area or responsibility. Luckily some on my team takes care of that because Lord knows I’m not going to remember

5 Likes

#10

Does anyone have a different fix? The things the tech worker mentions have nothing to do with my Firefox menu.

I’d been using (plain) Adblock and uBlock mobile on my phone, and anything I try to download from the add-ons says it is corrupt.

2 Likes

#11

using chromium

4 Likes

#12

I’ve been using Firefox Focus on my phone. It isn’t quite the same as the normal mobile Firefox, the UI’s a bit quirky and limited, but it does have some blockers built-in, and since they’re not plugins it doesn’t appear to be affected.

4 Likes

#13

so here’s a weird one.
updated FF last night, the new version has the fix and all my extensions came back.
I browsed and posted here and the other place. I even posted in the similar thread to this over at the other place.
just now I tried to load bbs pages over there and they’re all blank.
like, it blanks out, the page loads, says it’s stopped loading, and it remains blank.
the main page says new topics have “x-number comments” on the link.
I’m on Android.

if it’s related to the fix, why did it let me post yesterday after I updated?
if it’s related to one of my extensions, i was running them all yesterday.

must be something unrelated? but the timing is suspicious and nothing else changed.

6 Likes

#14

I’ve updated my Firefox too, though now I can’t find AdBlock in the play store anymore. Only the zombie creations that copy its name.

What I don’t understand is why Mozilla didn’t push the fix or even say much publicly? I had to to go looking for it.

4 Likes

#15

Is there a uBlock Origin for Firefox on your phone? I use it on Windows.

5 Likes

#16

I was using the mobile version, but I’ve found Origin works fine, too.

During the downtime I was using a free sample of Malwarebytes.

3 Likes

#17

The adblock browser for ios was okay. Apart from the ordinary bugginess in rendering, like the 3/5ths width edit box that began happening recently here.

4 Likes

#18

so I tried disabling my add-ons one by one and got bbs.otherplace pages to load once I turned off NoScript (!)
the bbs here loads normally with NoScript and otherplace did too as of 2 days ago.
seems sketchy as hell. I don’t want to whitelist it because it makes
me paranoid they’ve started running shitty scripts over there to track us for ad targeting etc, what with all the sponsored posts etc since Jason took over.

ideas anyone?

EDIT: user goatcheezeinferno coached me thru whitelisting just the discourse.cdn which fixed it. my question is why did it just now need whitelisting, and why just for over there and not here? but anyway it’s all good, I guess.

3 Likes

#19

We don’t make use of Jeff’s Premium Hosted Discourse And CDN Service (henceforth referred to as Discourse for Enterprise). Like another fun instance - Waypoint - we’re self-hosted on a rented VM from DigitalOcean.

Any Discourse for Enterprise instances make use of CDN.

5 Likes

#20

well, that does explain here vs there.
I asked jeff what was going on and he was like “you can’t block JavaScript, we’re a js service.” ok thnx.
but anyway something at the .cdn must have changed recently I guess.

6 Likes