Site Bugs?

I don’t see a thread for these.

But if I write a reply, see that it’s not shown as a reply, delete the malformed post, and rewrite the reply, I get an error message. So I add a few extra characters, it goes through, I try to delete the extra characters, I get an error message.


My preference would be to create a new thread/topic for each bug, rather than having a single thread for all bugs. This is the best category for these kinds of topics, though.

Can you describe your issue with more detail?

Are you on a desktop/laptop or a phone/tablet? What OS? What browser? Do you have any extensions installed that may interfere with the site? Have you tried temporarily disabling them or temporarily white-listing

Are you replying to a topic (with the blue reply button at the bottom) or to a post (with the grey/white reply button on the post?)

How do you know it’s not shown as a reply? What are you expecting that you’re not seeing?

Are you deleting the post after you’ve posted it, or are you just clearing the draft?

What steps are you going through to rewrite the reply? What is the error message that you’re getting?

Are you editing the post after clicking reply? What error message are you getting in this case?

Feel free to provide screenshots for any of these if you think it will help.

Also, keep in mind that I’m only hosting this software. I do not actively work on the code of Discourse, and I am not a Ruby developer. If we can’t find something on your end that’s causing the issue, I can report it at They’ve been responsive in the past, but I don’t have any influence over how they might prioritize what I report.

Hopefully we can figure something out, but I just wanted to be as transparent as possible.


There’s a minimum limit in Discourse on the length of a post. It has to be 6 characters or more. Any chance you are not writing long enough posts?


The configured minimum is 1 here. It’s 10 for a user’s first post, but 1 for each after that, so that’s probably not the issue here.




I tried to reply to a post. I typed it up. I submitted it. I saw it didn’t have a link to the previous post so I had to start over. I deleted it. I clicked reply on the previous post. I typed it up. I submitted it. I got an error message saying it was too much like my previous post. Because it was the previous post, with the right link. I tried again. I got the error message again. I added three dots. It got through. I went to edit the post to remove the dots. I got the error message again. There ought to be some way to fix a post.

Laptop-as-desktop. I can’t use pains, and I haven’t found any accessible tablets. They’re all touch devices these days. I currently use MacOS. I currently use Firefox 52 esr, with a couple dozen fixes to block animation. Unfortunately most other browsers have built-in animation.

and while “use safe mode, [which will turn off all your safety fixes],” is standard debugging advice, it isn’t safe.

I was trying to reply to a post but the first time, ended up replying to the topic, so I had to delete that and tried to redo my post.

A link to the post I was replying to.

After I posted it, and saw it didn’t have the link.

I was typing the post again. And getting a reply that it was too similar to itself.

Yes, to get past the error message, and then to remove the dots I had to use to get past the error message, but I couldn’t delete them without getting the same error message.


I seem to recall that it doesn’t show the link to the post if you’re post is immediately next. Could it be this?

1 Like

I think that should be covered by this setting:

I double-checked, but this has been disabled for some time.

1 Like

The bug is that, since the first post had the wrong formatting, so I deleted it, the right-formatting post couldn’t have the right text.

1 Like

I’m not sure if I can help with the primary issue yet, but I may be able to alleviate the secondary issue somewhat:


I’ve modified this to 1. That should allow you to re-post the deleted post after only one minute, instead of waiting five or adding garbage to work around the limitation.

I’m still going to review your notes some more and see if there is a more effective solution.


I’ve been meaning to ask about this for a while now;

Am I supposed to get a system notification every time I post an image?



The Other Place did that too.

After five minutes, it caches the image locally, and edits your post to point to the locally-cached copy. That’s when you get the notification.

I complained about it there, but they never took action to fix it.


Not for me; I’ve never gotten a system notification over there - and as much as I post images, I’d certainly have noticed.


I’ll try to look into it. If it’s a setting I can change, I have no problem doing so. If it’s a software issue, the best I can do is ask upstream.


Okay, thanks.

It’s not a big deal; I was just wondering.


I recall this issue in the old place and it was fixed, which is why it no longer happens.


Found it:

Let me know if that resolves it.


Is that something you did or something I need to do?



I changed it. it was previously unchecked, and is now checked. It is a site-wide setting.


Seems to have worked; though I won’t know for sure for a few minutes.